Jump to content
Austin Elling

Filter Parameter not functioning

Recommended Posts

I would like to create a direct link to my Trumba calendar using the filter parameter, but when I follow the Trumba documentation to create the filter parameter to put into the URL it always redirects to the main calendar page with no filter being set. My calendar is http://www.trumba.com/calendars/iowadecalendar

 

I want to set the filter to http://www.trumba.com/calendars/iowadecale...lter1=Deadlines, which according to the documentation should work. Any assistance would be appreciated. Thanks.

Share this post


Link to post
Share on other sites

Hi Austin,

Thanks for your question, and I'm so sorry about the delay in response. I've been trying to get the whole story on this, because it does appear now as if it works differently than it did just a few weeks ago, and the documentation is now out of date. So I'll sort that out myself, but in the meantime, I'll post the correct way to get this to work.

 

To use the URL parameters with the hosted page, we apparently need to bundle them URL-encoded inside the trumbaEmbed argument. The filter and search arguments in particular are a little more complicated, because they have to be encoded to handle multiple values and special characters. So, for your calendar, the parameter looks like this: filter1=_Deadlines_, and the entire URL would look like the one in the following code section (the equals sign that's part of the parameter bundled inside the trumbaEmbed argument needs to be encoded as %3D):

http://www.trumba.com/calendars/iowadecalendar?trumbaEmbed=filter1%3D_Deadlines_

Again, I'm sorry that the documentation is no longer correct, and I'll work on getting it updated asap. Thanks for reading it, though, and please let me know if you still have trouble with this.

 

Jill / Trumba UA

p.s. If you need to use multiple parameters with the ampersand character, you need to encode the ampersand as %26. If you search the Web for "url encoding" you can find sites that list the values for other special characters you might need.

Share this post


Link to post
Share on other sites

The filtering by Url does now work, however, my spud that does filtering today is no longer working on my calendar (http://www.iowa.gov/educate/calendar/calendar.html). It was working previously but now now the javascript does not even appear. When I try to preview on the administrator side it says I have a filtering spud available but nothing is displayed. It was working perfectly before today. Any help would be appreciated. Thanks

Share this post


Link to post
Share on other sites

Hi Austin,

I'm glad you figured out how to get your filter back! If it happens again, please let us know, and also try to think of any similarities between the occurrences. I haven't heard of this happening before, so we'd have to do a bit of troubleshooting to figure it out, and any details will help. Thanks, and again, glad you got yourself back up and running normally!

 

Jill / Trumba UA

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×