Jump to content
Sign in to follow this  
TLCDave

Need help with mixcontrol parameter

Recommended Posts

I must be missing something simple, but I've fooled with this and I can't get it to work. I'm trying to display a simple monthly calendar view without the mix-in control... my spud code looks like this:

 

$Trumba.addSpud(

{ webName: "mycalendarname",

spudType: "main",

url: { mixcontrol: "hide"} });

 

The calendar displays, but the mix-in control is always there. I've tried different url parameters and they seem to work as expected, so I think I have the basic syntax correct. What is it about the mixcontrol parameter that hates me?

Share this post


Link to post
Share on other sites

Welcome to the forums, TLCDave,

Gee, it might be comforting at least to know that it's not just you. The parameter isn't cooperating with me either, and I've tried a couple of different views. I'll check with our developer on this, but in the meantime, here's another way to turn off the mix-in list that appears with the main calendar:

  1. Display your Publishing Control Panel, and then in the top section, click Edit Publish Settings.
  2. On the publish settings page, under the Mix-in... section, select No for the setting Display embedded mix-in control.

This of course disables the control for all main spuds, not just the one you're working with. Do you want to remove it just for that one spud?

 

Jill / Trumba User Assistance

Share this post


Link to post
Share on other sites
Welcome to the forums, TLCDave,

Gee, it might be comforting at least to know that it's not just you. The parameter isn't cooperating with me either, and I've tried a couple of different views. I'll check with our developer on this, but in the meantime, here's another way to turn off the mix-in list that appears with the main calendar:

  1. Display your Publishing Control Panel, and then in the top section, click Edit Publish Settings.
  2. On the publish settings page, under the Mix-in... section, select No for the setting Display embedded mix-in control.

This of course disables the control for all main spuds, not just the one you're working with. Do you want to remove it just for that one spud?

 

Jill / Trumba User Assistance

 

Thanks for the reply. Yeah, this calendar is also embedded in another related website and I didn't really want to change its appearance there. That's why this mixcontrol parameter seemed like just the ticket. Forgive the newbie question (I didn't create the calendar or publish it, so I don't know exactly what's possible), but can the same calendar be published with more than one name (e.g. "publish as <newCalendarName>")? That is, can I do what you suggested, publishing it with a new name that I can reference rather than the existing one?

Share this post


Link to post
Share on other sites

Hi TLCDave,

The developers have confirmed that the parameter is no longer working. I believe one of them will be reimplementing it soon. I haven't gotten a timeframe yet, but I'll try, and I'll post again when I know more. I know that the developer is working on something else that will be released this week, so the parameter will probably not be back this week. I'm sorry that it stopped working, and I appreciate that you asked about it.

 

Jill / Trumba UA

Share this post


Link to post
Share on other sites

Hi TLCDave,

In case you're still lurking and haven't gotten this info yet, the mixcontrol parameter has been reimplemented as described in the Help that you saw before. The spud code you posted in your original message should work to disable it. Thanks for letting us know it wasn't working!

 

Jill / Trumba UA

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×