Jump to content

Recommended Posts

Over the past couple of weeks, we've been having trouble logging in, even though we have the correct username and password. Even after I delete cache and cookies, I'm unable to login in one browser (redirects back to the login screen), but then I can immediately open another browser and login successfully. Would you please let me know what more you need to troubleshoot this? (I've had it work both ways - can't login in FF, can login in IE and vice-versa, for instance.)

Share this post


Link to post
Share on other sites

If you're having trouble signing in to your Trumba account:


  • First, verify that you're using the correct email address and password.

  • If your credentials are correct and you still can't sign in, click this link to force a full sign out. Then, try signing in again.

  • If you're still having trouble, please use your browser settings to delete all cookies. Then restart the browser, and try signing in again.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...