Jump to content
Sign in to follow this  
Matt Taylor

Trumba spud embed on non-UTF-8 encoded webpage

Recommended Posts

I have an interesting issue. Right now I am working to implement a calendar spud onto a webpage of our site.

Our university web server is running Apache and with the current configuration, it is ignoring my source code declaration to use UTF-8 (instead it forces all pages to Western European encoding).

The only noticeable display issue I have noticed is that when I roll over the titles of mixed in sub-calendars it displays this weird character in the text that pops up.

I know ideally Trumba suggests UTF-8 encoding for everything to display correctly. I know one concern our IT Dept had though was that the server supports many department websites and if they make a global configuration change if it would break/cause display errors for the other non-UTF-8 sites. Do you have any ideas or suggestions for how an Apache web server should be configured to allow UTF-8 webpages but also default to the Western European encoding if there is no declaration? I know our IT department is very busy with various projects and so I wanted to try to provide them with as much information as I could to not drain their time. Right now all of the sites on the server use the Western European encoding and so they want to be careful to make sure that making my site work doesn't cause unintended display errors on the other sites.

Share this post


Link to post
Share on other sites

I think the unusual character is what you are seeing in the place of something that ought to look like ">>". This character is displayed only if the calendar is a subcalendar rather than Top-level calendar. It is very easy to change a calendar to be a Top-level calendar by using the down arrow to the right of the calendar name (when you are signed into your account) and selecting Calendar Settings. So, one approach would be to continue to mix the calendars in, but to make them each a top level calendar.

If you can provide us additional information on the browsers that you are trying, it will help us with duplicating the issue.

Share this post


Link to post
Share on other sites

I heard back from our IT department much quicker than I expected and they were able to show me how to setup a .htaccess file that enables the UTF-8 encoding statements in my source code for pages to work. So, they didn't have to change a global server configuration, but rather just help set me up with a .htaccess file that has a command that allows my site to use a different encoding without affecting the other sites on the server at all.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...